Fix module build (Use pkgconfig instead of deprecated enlightenment-config).

SVN revision: 36660
master
Cedric BAIL 14 years ago
parent d42cafd178
commit 9cf030636d
  1. 6
      Makefile.am
  2. 7
      configure.in

@ -23,7 +23,7 @@ EXTRA_DIST = $(files_DATA) \
INCLUDES = -I. \
-I$(top_srcdir) \
-I$(includedir) \
@e_cflags@
@E_CFLAGS@
pkgdir = $(datadir)/$(MODULE_ARCH)
pkg_LTLIBRARIES = module.la
@ -31,8 +31,8 @@ module_la_SOURCES = e_mod_main.c \
e_mod_main.h \
e_mod_config.c \
e_mod_config.h
module_la_LIBADD = @e_libs@
module_la_LIBADD = @E_LIBS@
module_la_LDFLAGS = -module -avoid-version
module_la_DEPENDENCIES = $(top_builddir)/config.h

@ -31,12 +31,7 @@ AC_DEFINE_UNQUOTED(MODULE_ARCH, "$MODULE_ARCH", "Module architecture")
AC_PATH_PROG(EDJE_CC, "edje_cc", "", $PATH)
AC_PATH_PROG(E_CONFIG, "enlightenment-config", "", $PATH)
e_cflags=`$E_CONFIG --cflags`
e_libs=`$E_CONFIG --libs`
e_modules=`$E_CONFIG --module-dir`
AC_SUBST(e_cflags)
AC_SUBST(e_libs)
PKG_CHECK_MODULES(E, [enlightenment])
datadir="${e_modules}/${PACKAGE}"
AC_ARG_ENABLE(homedir-install,

Loading…
Cancel
Save