aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Andreoli <dave@gurumeditation.it>2017-07-22 18:10:16 +0200
committerDave Andreoli <dave@gurumeditation.it>2017-07-22 18:10:16 +0200
commit85e23f2851b79f2ac76e0a6ad15c99df35563483 (patch)
treef5f2e8e1427f3429605b48129f787c1843c20230
parentNew 1.20 API: elm.Menu.open() (diff)
downloadpython-efl-85e23f2851b79f2ac76e0a6ad15c99df35563483.tar.gz
Prepare the 1.20.0-beta1 pre-release
-rw-r--r--ChangeLog21
-rwxr-xr-xapi_coverage.py5
-rw-r--r--efl/__init__.py4
3 files changed, 28 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 1fb2315..7c0c153 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,26 @@
===================
+2017-07-22 v1.20.0
+===================
+
+Fixes:
+ * ecore.input and ecore.x can now coexsist
+
+Changes:
+ * ecore.Poller is no more an Eo object in C (nothing should be changed in py)
+ * removed edje.Object custom __repr__ implementation
+
+Additions:
+ * elm.Entry.prediction_hint
+ * elm.Genlist.multi_select_mode
+ * elm.Menu.open()
+ * elm.Spinner.callback_max_reached_add()
+ * elm.Spinner.callback_max_reached_del()
+ * edje.part_text_prediction_hint_set()
+ * evas.Map.coords_get()
+
+
+===================
2017-04-18 v1.19.0
===================
diff --git a/api_coverage.py b/api_coverage.py
index 69da5f2..ebf02ce 100755
--- a/api_coverage.py
+++ b/api_coverage.py
@@ -25,6 +25,11 @@ c_exclude_list = [
"elm_config_access", # Access disabled until 1.9
"elm_object_item_access", # Access disabled until 1.9
"elm_systray", # We currently have this in using Eo API
+ "elm_code_", # The code widget is still in beta
+ "elm_need_e_dbus", # has been deprecated long time ago
+ "elm_check_selected_get", # We already provide state_get
+ "elm_check_selected_set", # We already provide state_set
+
]
c_excludes = "|".join(c_exclude_list)
diff --git a/efl/__init__.py b/efl/__init__.py
index 3950920..a81640e 100644
--- a/efl/__init__.py
+++ b/efl/__init__.py
@@ -20,5 +20,5 @@
# pre-release: "1.13.0-beta1" ( 1, 13, 0 )
# release: "1.13.0" ( 1, 13, 0 )
-__version__ = "1.19.99"
-__version_info__ = ( 1, 19, 99 )
+__version__ = "1.20.0-beta1"
+__version_info__ = ( 1, 20, 0 )