summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2019-07-08 17:16:31 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2019-07-08 17:16:31 +0200
commit4b7d842d280025b9cf749715a7c44a2a0fc4779f (patch)
tree508a9a842f2263b43d75bd51cb52fe9d679c43a3
parent47c5736ef9198c2b41d98ade601114f329b69b24 (diff)
-rw-r--r--src/lib/efl/interfaces/efl_ui_range_display.eo15
-rw-r--r--src/lib/efl/interfaces/efl_ui_range_interactive.eo7
2 files changed, 9 insertions, 13 deletions
diff --git a/src/lib/efl/interfaces/efl_ui_range_display.eo b/src/lib/efl/interfaces/efl_ui_range_display.eo
index 39ca1b2113..352f017684 100644
--- a/src/lib/efl/interfaces/efl_ui_range_display.eo
+++ b/src/lib/efl/interfaces/efl_ui_range_display.eo
@@ -4,19 +4,19 @@ interface @beta Efl.Ui.Range_Display
4 c_prefix: efl_ui_range; 4 c_prefix: efl_ui_range;
5 methods { 5 methods {
6 @property range_value { 6 @property range_value {
7 [[Control the range value (in percentage) on a given range widget 7 [[Control the range value of a widget.
8
9 Use this call to set range levels.
10 8
11 Note: If you pass a value out of the specified interval for 9 Note: If you pass a value out of the specified interval for
12 $val, it will be interpreted as the closest of the boundary 10 $val, there will be an error. An exception to this are implementations that support clamping or modulos.
13 values in the interval.]] 11 ]]
14 set { 12 set {
13 [[Set the new value to the widget.]]
15 } 14 }
16 get { 15 get {
16 [[The value that is currently displayed.]]
17 } 17 }
18 values { 18 values {
19 val: double; [[The range value (must be between $0.0 and 1.0)]] 19 val: double; [[The range value (must be between $min and $max)]]
20 } 20 }
21 } 21 }
22 @property range_limits { 22 @property range_limits {
@@ -31,8 +31,7 @@ interface @beta Efl.Ui.Range_Display
31 31
32 The minimum and maximum values may be different for each class. 32 The minimum and maximum values may be different for each class.
33 33
34 Warning: maximum must be greater than minimum, otherwise behavior 34 Warning: maximum must be greater than minimum, otherwise an error is raised.
35 is undefined.
36 ]] 35 ]]
37 } 36 }
38 get { 37 get {
diff --git a/src/lib/efl/interfaces/efl_ui_range_interactive.eo b/src/lib/efl/interfaces/efl_ui_range_interactive.eo
index 817178c7b2..5f7903c926 100644
--- a/src/lib/efl/interfaces/efl_ui_range_interactive.eo
+++ b/src/lib/efl/interfaces/efl_ui_range_interactive.eo
@@ -13,11 +13,8 @@ interface @beta Efl.Ui.Range_Interactive extends Efl.Ui.Range_Display
13 13
14 By default step value is equal to 1. 14 By default step value is equal to 1.
15 15
16 Warning: The step value should be bigger than 0.]] 16 Warning: The step value should be bigger than 0.0.
17 set { 17 ]]
18 }
19 get {
20 }
21 values { 18 values {
22 step: double; [[The step value.]] 19 step: double; [[The step value.]]
23 } 20 }