summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2017-04-28 16:00:52 +0200
committerStefan Schmidt <stefan@osg.samsung.com>2017-04-28 16:09:46 +0200
commit4029b99bb42079aea35642197d77e66c89ca10b5 (patch)
treef6fc88cd277739b59dbdd2813d61e57dff0ca4ac
parent88faca55910dad33bb70d9758e3f2a1c865b7ba4 (diff)
bump minimum version requirement of freetype2 to 16.2.10 which equals release 2.5.0.1
For this one I feel like I earned an archaeologist medal. :-) This is related to the commit raster made in aa92cddb to accommodate for older freetype version. The TT_INTERPRETER_VERSION_35 define was actually introduced in the release 2.5.0 which was released in June 2013 which means it had almost 4 years to get picked up. I would consider this safe to be a minimum dependency for current efl versions. The trick here is that the release version does not match the library version spit out by pkg-config. 16.2.10 equals the freetype 2.5.0.1 release in this case. Better make a note about it in configure for the next poor soul trying to understand this. Thanks again to llelectronics for reporting this. Fix T5437 @fix
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2fe8af5b05..70f3a09451 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2473,8 +2473,8 @@ EFL_INTERNAL_DEPEND_PKG([EVAS], [ecore])
2473 2473
2474EFL_ADD_LIBS([EVAS], [-lm]) 2474EFL_ADD_LIBS([EVAS], [-lm])
2475 2475
2476# Freetype 2476# Freetype (the version 16.2.10 equals the freetype 2.5.0.1 release)
2477EFL_DEPEND_PKG([EVAS], [FREETYPE], [freetype2 >= 9.3.0]) 2477EFL_DEPEND_PKG([EVAS], [FREETYPE], [freetype2 >= 16.2.10])
2478 2478
2479## optional dependencies 2479## optional dependencies
2480 2480