summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-08-02 16:54:56 +0900
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2017-08-02 17:01:12 +0900
commit886fb0a782d8b0b969f61115b8b0e4e5b3bf6dc2 (patch)
tree453313cd4e9a4397ccbb6bf552de7af9077fe36f
parent7718b4c0eaae1785047d4729ad68ac9eb7e1d40a (diff)
efl build - fix lua old support on debian
didnt detect cflags properly. now it does. @fix
-rw-r--r--configure.ac2
-rw-r--r--m4/efl_lua_old.m48
2 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8bb4395175..7e4c17719d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4815,7 +4815,7 @@ fi
4815dnl EFL_OPTIONAL_INTERNAL_DEPEND_PKG([EDJE], [${want_physics}], [ephysics]) 4815dnl EFL_OPTIONAL_INTERNAL_DEPEND_PKG([EDJE], [${want_physics}], [ephysics])
4816 4816
4817if test "x${want_lua_old}" = "xyes"; then 4817if test "x${want_lua_old}" = "xyes"; then
4818 EFL_CHECK_LUA_OLD([EDJE_LUA]) 4818 EFL_CHECK_LUA_OLD([EDJE])
4819else 4819else
4820 PKG_CHECK_MODULES([EDJE_LUA], [luajit >= 2.0.0]) 4820 PKG_CHECK_MODULES([EDJE_LUA], [luajit >= 2.0.0])
4821fi 4821fi
diff --git a/m4/efl_lua_old.m4 b/m4/efl_lua_old.m4
index ff8a33a4bb..537a6f336b 100644
--- a/m4/efl_lua_old.m4
+++ b/m4/efl_lua_old.m4
@@ -25,6 +25,12 @@ if test "x${requirement_lua}" = "x"; then
25 AC_MSG_ERROR([Missing lua 5.1 or 5.2 support]) 25 AC_MSG_ERROR([Missing lua 5.1 or 5.2 support])
26 fi 26 fi
27else 27else
28 EFL_DEPEND_PKG([$1], [LUA], [${requirement_lua}]) 28 req_found="no"
29 EFL_DEPEND_PKG([$1], [LUA], [${requirement_lua}],
30 [ req_found="yes" ],
31 [ req_found="no" ])
32 if test "x${req_found}" = "xyes"; then
33 PKG_CHECK_MODULES([$1]_LUA, [${requirement_lua}])
34 fi
29fi 35fi
30]) 36])