summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2017-04-28 15:25:45 +0200
committerStefan Schmidt <stefan@osg.samsung.com>2017-04-28 15:25:45 +0200
commit88faca55910dad33bb70d9758e3f2a1c865b7ba4 (patch)
tree204b29577f11c4cf978bfd9999e9ecba845b587c
parent1b523a985a8a89851773c660ab36462de8136c24 (diff)
build: bump minimum version requirement of gnutls to 3.3.6
This releases offers the gnutls_certificate_set_x509_trust_dir() API we use in ecore_con. This gnutls version was release in July 2014 which gave it enough time to be picked up by distributions. Thanks a lot to llelectronics for reporting and tracking down the problem. ref T5437 @fix
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 51d7324178..2fe8af5b05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,7 +388,7 @@ AM_CONDITIONAL([EFL_ENABLE_TESTS], [test "${want_tests}" = "yes"])
388# check for crypto/tls library to use 388# check for crypto/tls library to use
389case "$build_crypto" in 389case "$build_crypto" in
390 gnutls) 390 gnutls)
391 EFL_DEPEND_PKG([crypto], [GNUTLS], [gnutls >= 2.12.16]) 391 EFL_DEPEND_PKG([crypto], [GNUTLS], [gnutls >= 3.3.6])
392 392
393 AM_PATH_LIBGCRYPT([], [:], 393 AM_PATH_LIBGCRYPT([], [:],
394 [AC_MSG_ERROR([libgcrypt required but not found])]) 394 [AC_MSG_ERROR([libgcrypt required but not found])])