aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Michael <cp.michael@samsung.com>2013-08-07 07:46:43 +0100
committerChris Michael <cp.michael@samsung.com>2013-08-07 07:46:43 +0100
commit8f755af29f038996595870bbcd3368dd1baed9d2 (patch)
treec22e45fd100bc16056beb14b523b1ceea92dd34f
parentAdd wayland library version checks to configure.ac for EFL 1.8 (diff)
downloadefl-8f755af29f038996595870bbcd3368dd1baed9d2.tar.gz
Require up-to-date versions of the wayland libraries for evas engine
support. Signed-off-by: Chris Michael <cp.michael@samsung.com>
-rw-r--r--m4/evas_check_engine.m44
1 files changed, 2 insertions, 2 deletions
diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4
index 907bc8c155..1cc11bb510 100644
--- a/m4/evas_check_engine.m4
+++ b/m4/evas_check_engine.m4
@@ -519,7 +519,7 @@ have_dep="no"
evas_engine_[]$1[]_cflags=""
evas_engine_[]$1[]_libs=""
-PKG_CHECK_EXISTS([wayland-client],
+PKG_CHECK_EXISTS([wayland-client >= 1.2.0],
[
have_dep="yes"
requirement="wayland-client"
@@ -560,7 +560,7 @@ else
gl_library="gl"
fi
-PKG_CHECK_EXISTS([egl >= 7.10 ${gl_library} wayland-client wayland-egl],
+PKG_CHECK_EXISTS([egl >= 7.10 ${gl_library} wayland-client >= 1.2.0 wayland-egl >= 9.2.0],
[
have_dep="yes"
requirement="egl >= 7.10 ${gl_library} wayland-client wayland-egl"