summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Philippe Andre <jp.andre@samsung.com>2016-06-07 16:25:45 +0900
committerJean-Philippe Andre <jp.andre@samsung.com>2016-06-07 16:29:13 +0900
commitf3b625e5477acf451dda02d6577bcf3ef0b3b83d (patch)
tree5eabd3046b3c0ec0f69e1460658a4227432fde7e
parenta6fe58364a4b16e9adc23f2be058b6ec8bf4d394 (diff)
pdf: Fix build with poppler >= 0.40
This disables PDF load if poppler >= 0.40 (current is 0.42 on my machine). Those image loaders definitely should be explicitely enabled or disabled, not enabled based on the system.
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c411a836ba..9416b5f1d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2880,7 +2880,7 @@ if test "x${want_poppler}" = "xyes"; then
2880 fi 2880 fi
2881 2881
2882 if test "x${have_poppler}" = "xno" ; then 2882 if test "x${have_poppler}" = "xno" ; then
2883 PKG_CHECK_EXISTS([poppler >= 0.31], 2883 PKG_CHECK_EXISTS([poppler >= 0.31 poppler < 0.40],
2884 [ 2884 [
2885 poppler_pc="poppler >= 0.31" 2885 poppler_pc="poppler >= 0.31"
2886 AC_DEFINE(HAVE_POPPLER_031, 1, [Have poppler 0.31]) 2886 AC_DEFINE(HAVE_POPPLER_031, 1, [Have poppler 0.31])