summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Bail <cedric.bail@free.fr>2014-04-27 12:02:53 +0200
committerCedric Bail <cedric.bail@free.fr>2014-04-27 12:02:53 +0200
commit335e8c0b9155e7b5f8adc880a0e454ea3ab825d7 (patch)
treecd5412d3fdbe0fe4dbb03480e9e16a2e0fbaad87 /configure.ac
parent9873ced7a433c0b09cee80b26a2822e144cf2da3 (diff)
autotools: enable lua old support before testing for it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 19 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index f3339d5..48014f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -365,6 +365,25 @@ esac
365AM_CONDITIONAL([HAVE_CRYPTO_GNUTLS], [test "${build_crypto}" = "gnutls"]) 365AM_CONDITIONAL([HAVE_CRYPTO_GNUTLS], [test "${build_crypto}" = "gnutls"])
366AM_CONDITIONAL([HAVE_CRYPTO_OPENSSL], [test "${build_crypto}" = "openssl"]) 366AM_CONDITIONAL([HAVE_CRYPTO_OPENSSL], [test "${build_crypto}" = "openssl"])
367 367
368# check for lua old
369want_lua_old="no"
370AC_ARG_ENABLE([lua-old],
371 [AC_HELP_STRING([--enable-lua-old],
372 [Enable interpreted Lua support (5.1 or 5.2). @<:@default=disabled@:>@])],
373 [
374 if test "x${enableval}" = "xyes" ; then
375 want_lua_old="yes"
376 else
377 want_lua_old="no"
378 fi
379 ],
380 [want_lua_old="no"])
381
382AM_CONDITIONAL([ENABLE_LUA_OLD], [test "${want_lua_old}" = "yes"])
383AC_DEFINE_IF([ENABLE_LUA_OLD], [test "${want_lua_old}" = "yes"],
384 [1], [Use interpreted Lua (5.1 or 5.2)])
385AC_SUBST([want_lua_old])
386
368#### Checks for header files 387#### Checks for header files
369 388
370# Common Checks (keep names sorted for ease of use): 389# Common Checks (keep names sorted for ease of use):
@@ -3789,19 +3808,6 @@ AC_ARG_ENABLE([multisense],
3789 ], 3808 ],
3790 [want_multisense="no"]) 3809 [want_multisense="no"])
3791 3810
3792want_lua_old="no"
3793AC_ARG_ENABLE([lua-old],
3794 [AC_HELP_STRING([--enable-lua-old],
3795 [Enable interpreted Lua support (5.1 or 5.2). @<:@default=disabled@:>@])],
3796 [
3797 if test "x${enableval}" = "xyes" ; then
3798 want_lua_old="yes"
3799 else
3800 want_lua_old="no"
3801 fi
3802 ],
3803 [want_lua_old="no"])
3804
3805# TODO: should we keep or remove these? 3811# TODO: should we keep or remove these?
3806want_edje_program_cache="no" 3812want_edje_program_cache="no"
3807want_edje_calc_cache="yes" 3813want_edje_calc_cache="yes"
@@ -3855,10 +3861,6 @@ AM_CONDITIONAL([ENABLE_MULTISENSE], [test "${want_multisense}" = "yes"])
3855AC_DEFINE_IF([ENABLE_MULTISENSE], [test "${want_multisense}" = "yes"], 3861AC_DEFINE_IF([ENABLE_MULTISENSE], [test "${want_multisense}" = "yes"],
3856 [1], [Use Multisense]) 3862 [1], [Use Multisense])
3857AC_SUBST([want_multisense]) 3863AC_SUBST([want_multisense])
3858AM_CONDITIONAL([ENABLE_LUA_OLD], [test "${want_lua_old}" = "yes"])
3859AC_DEFINE_IF([ENABLE_LUA_OLD], [test "${want_lua_old}" = "yes"],
3860 [1], [Use interpreted Lua (5.1 or 5.2)])
3861AC_SUBST([want_lua_old])
3862AC_SUBST([want_physics]) 3864AC_SUBST([want_physics])
3863 3865
3864### Checks for header files 3866### Checks for header files