summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2016-01-13 17:03:36 +0100
committerStefan Schmidt <stefan@osg.samsung.com>2016-01-13 17:06:39 +0100
commitd1609c2afe0e91c8a38b000545ed8137e49dc184 (patch)
treeea3558e623dc56647b647b56333065e356e011e1 /configure.ac
parent2d17f7894e931c50728bc4651b07a01c88644f5f (diff)
ecore_drm: make sure we include math.h and link against libm for floor()
When we introduced the usage of floor() in ecore_drm_evdev.c we forgot to include math.h for it as well as linking against libm. This caused linking failures on some systems while it still worked on others. Better fix it for good. Original patch by aerodynamik. ref T2953
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0ee5a4c..facdb5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3472,6 +3472,8 @@ EFL_INTERNAL_DEPEND_PKG([ECORE_DRM], [eina])
3472EFL_DEPEND_PKG([ECORE_DRM], [DRM], [libdrm >= 2.4 xkbcommon >= 0.3.0 gbm]) 3472EFL_DEPEND_PKG([ECORE_DRM], [DRM], [libdrm >= 2.4 xkbcommon >= 0.3.0 gbm])
3473EFL_DEPEND_PKG([ECORE_DRM], [LIBINPUT], [libinput >= 0.6.0]) 3473EFL_DEPEND_PKG([ECORE_DRM], [LIBINPUT], [libinput >= 0.6.0])
3474 3474
3475EFL_ADD_LIBS([ECORE_DRM], [-lm])
3476
3475# API change from 0.7 to 0.8. So we define this to support both for now. 3477# API change from 0.7 to 0.8. So we define this to support both for now.
3476PKG_CHECK_EXISTS([libinput >= 0.8.0], 3478PKG_CHECK_EXISTS([libinput >= 0.8.0],
3477 [have_libinput_new="yes"], 3479 [have_libinput_new="yes"],