summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorU. Artie Eoff <ullysses.a.eoff@intel.com>2013-08-13 08:16:22 -0700
committerU. Artie Eoff <ullysses.a.eoff@intel.com>2013-08-13 08:16:22 -0700
commit56ca91dec05216f082867efa533b15b18773f822 (patch)
treeebb1b1b115dfda1a6a554876bab323ef222939d9 /configure.ac
parent337b3d4daf7dbcc63b63724416137f15f3e9e426 (diff)
configure: relax xkbcommon version requirement for ecore-wayland
Summary: Allow ecore-wayland to be configured and compiled with xkbcommon 0.3.0. Ecore-wayland does not use any of the new APIs in 0.3.1 nor is it exposed to the bug that was fixed in 0.3.1. Most distros don't include xkbcommon > 0.3.0 yet. Thus, if 0.3.1 is required right now, then everyone is forced to build xkbcommon, too, which contributes to dependency *madness*. Of course, anyone is still welcome to build and link to xkbcommon 0.3.1 at will. Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com> Reviewers: devilhorns, antognolli Reviewed By: devilhorns Differential Revision: https://phab.enlightenment.org/D203
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 148d093ee5..ebb7a7bdb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2370,7 +2370,7 @@ EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eo])
2370EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eina]) 2370EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eina])
2371 2371
2372EFL_DEPEND_PKG([ECORE_WAYLAND], [WAYLAND], 2372EFL_DEPEND_PKG([ECORE_WAYLAND], [WAYLAND],
2373 [wayland-client >= 1.2.0 wayland-cursor >= 1.2.0 xkbcommon >= 0.3.1]) 2373 [wayland-client >= 1.2.0 wayland-cursor >= 1.2.0 xkbcommon >= 0.3.0])
2374 2374
2375EFL_EVAL_PKGS([ECORE_WAYLAND]) 2375EFL_EVAL_PKGS([ECORE_WAYLAND])
2376 2376