summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 21:37:47 +0000
committerGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 21:37:47 +0000
commitf9c314d07c9df284ee02a28aa084d98bfb4ab0fc (patch)
treee2596c3c3d5232c05f40a67b9cd045f0498df9b5 /configure.ac
parentadfcc2112ef230d43978f0ad4f59c9d3997f9a4a (diff)
efl: do not support old pkg-config.
if the distro still wants to support the SUPER OLD pkg-config, then it will have to fix the generated .pc before installing them: {{{ sed -i 's/^Requires.private:/Requires:/g' pc/*.pc }}} SVN revision: 77818
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 9d0fa93099..f1a07782ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,14 +169,6 @@ if test "x${PKG_CONFIG}" = "x" ; then
169 AC_MSG_ERROR([pkg-config tool not found. Install it or set PKG_CONFIG environment variable to that path tool. Exiting...]) 169 AC_MSG_ERROR([pkg-config tool not found. Install it or set PKG_CONFIG environment variable to that path tool. Exiting...])
170fi 170fi
171 171
172# Check whether pkg-config supports Requires.private
173if ${PKG_CONFIG} --atleast-pkgconfig-version 0.22 ; then
174 pkgconfig_requires_private="Requires.private"
175else
176 pkgconfig_requires_private="Requires"
177fi
178AC_SUBST([pkgconfig_requires_private])
179
180# doxygen program for documentation building 172# doxygen program for documentation building
181 173
182EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"]) 174EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])