summaryrefslogtreecommitdiff
path: root/legacy/elementary/src/lib/elm_widget_entry.h
diff options
context:
space:
mode:
authorDaniel Juyung Seo <seojuyung2@gmail.com>2014-08-08 01:26:47 +0900
committerDaniel Juyung Seo <seojuyung2@gmail.com>2014-08-08 01:29:39 +0900
commit5a4ca7008f4392cd192dd0f9594917d789acc022 (patch)
tree6f78e4ae41e2a9b3936d7ccdbcd23d65d9598d04 /legacy/elementary/src/lib/elm_widget_entry.h
parentedd78dc90f9c144003afc49a414f5000264765f2 (diff)
widget: added warnings to internal headers.
These headers are installed in the system but not officially supported as they are considered as internal headers. The reason why they still need to be installed is that - they were exposed even in the previous releases. - they are needed for widget customization (unofficially) - or it will break ewe. Special thanks to Stefan for the reporting.
Diffstat (limited to '')
-rw-r--r--legacy/elementary/src/lib/elm_widget_entry.h6
1 files changed, 6 insertions, 0 deletions
diff --git a/legacy/elementary/src/lib/elm_widget_entry.h b/legacy/elementary/src/lib/elm_widget_entry.h
index 030ec73..06b4dda 100644
--- a/legacy/elementary/src/lib/elm_widget_entry.h
+++ b/legacy/elementary/src/lib/elm_widget_entry.h
@@ -4,6 +4,12 @@
4#include "elm_interface_scrollable.h" 4#include "elm_interface_scrollable.h"
5#include "elm_widget_layout.h" 5#include "elm_widget_layout.h"
6 6
7/* DO NOT USE THIS HEADER UNLESS YOU ARE PREPARED FOR BREAKING OF YOUR
8 * CODE. THIS IS ELEMENTARY'S INTERNAL WIDGET API (for now) AND IS NOT
9 * FINAL. CALL elm_widget_api_check(ELM_INTERNAL_API_VERSION) TO CHECK
10 * IT AT RUNTIME.
11 */
12
7/** 13/**
8 * @addtogroup Widget 14 * @addtogroup Widget
9 * @{ 15 * @{