summaryrefslogtreecommitdiff
path: root/legacy/emotion/configure.ac
diff options
context:
space:
mode:
authorCarsten Haitzler <raster@rasterman.com>2012-03-17 06:25:41 +0000
committerCarsten Haitzler <raster@rasterman.com>2012-03-17 06:25:41 +0000
commitfed5f7943352b7bdd153c4a5564f6030728ee15e (patch)
treeba589cf604d18f54e369a9ada28415104012c286 /legacy/emotion/configure.ac
parent1bdfdad0691281cc351775d54d5fa7337920f0fa (diff)
and work more on getting release in shape - version requirements.
(god this is a pain in the butt) SVN revision: 69484
Diffstat (limited to '')
-rw-r--r--legacy/emotion/configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/legacy/emotion/configure.ac b/legacy/emotion/configure.ac
index d41d5cc32f..37edf6ac3b 100644
--- a/legacy/emotion/configure.ac
+++ b/legacy/emotion/configure.ac
@@ -108,16 +108,16 @@ EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])
108 108
109### Checks for libraries 109### Checks for libraries
110 110
111PKG_CHECK_MODULES(EMOTION, [eina >= 1.0.0 evas >= 1.0.0 ecore >= 1.0.0 eet >= 1.4.0]) 111PKG_CHECK_MODULES(EMOTION, [eina >= 1.2.0 evas >= 1.2.0 ecore >= 1.2.0 eet >= 1.6.0])
112requirement_emotion="ecore >= 1.0.0 evas >= 1.0.0 eina >= 1.0.0 eet >= 1.4.0" 112requirement_emotion="ecore >= 1.2.0 evas >= 1.2.0 eina >= 1.2.0 eet >= 1.6.0"
113 113
114if test "x${have_emotion_test}" = "xyes" ; then 114if test "x${have_emotion_test}" = "xyes" ; then
115 PKG_CHECK_MODULES(EMOTION_BIN, [eina >= 1.0.0 evas >= 1.0.0 ecore >= 1.0.0 ecore-evas >= 1.0.0 edje >= 1.0.0]) 115 PKG_CHECK_MODULES(EMOTION_BIN, [eina >= 1.2.0 evas >= 1.2.0 ecore >= 1.2.0 ecore-evas >= 1.2.0 edje >= 1.2.0])
116fi 116fi
117 117
118PKG_CHECK_MODULES(ECORE_X, [ecore-x >= 1.0.0 ecore-evas >= 1.0.0], [have_ecore_x="yes"], [have_ecore_x="no"]) 118PKG_CHECK_MODULES(ECORE_X, [ecore-x >= 1.2.0 ecore-evas >= 1.2.0], [have_ecore_x="yes"], [have_ecore_x="no"])
119 119
120PKG_CHECK_MODULES(ECORE_FB, [ecore-fb >= 1.0.0], [have_ecore_fb="yes"], [have_ecore_fb="no"]) 120PKG_CHECK_MODULES(ECORE_FB, [ecore-fb >= 1.2.0], [have_ecore_fb="yes"], [have_ecore_fb="no"])
121 121
122if test "x${have_ecore_x}" = "xyes" ; then 122if test "x${have_ecore_x}" = "xyes" ; then
123 AC_DEFINE(EMOTION_HAVE_ECORE_X, 1, [Define to 1 if Ecore_X is enabled]) 123 AC_DEFINE(EMOTION_HAVE_ECORE_X, 1, [Define to 1 if Ecore_X is enabled])
@@ -127,13 +127,13 @@ if test "x${have_ecore_fb}" = "xyes" ; then
127 AC_DEFINE(EMOTION_HAVE_ECORE_FB, 1, [Define to 1 if Ecore_Fb is enabled]) 127 AC_DEFINE(EMOTION_HAVE_ECORE_FB, 1, [Define to 1 if Ecore_Fb is enabled])
128fi 128fi
129 129
130PKG_CHECK_EXISTS([evas-software-x11 >= 1.0.0], [AC_DEFINE(HAVE_EVAS_SOFWARE_X11, 1, [Evas Software Xlib Engine Support])]) 130PKG_CHECK_EXISTS([evas-software-x11 >= 1.2.0], [AC_DEFINE(HAVE_EVAS_SOFWARE_X11, 1, [Evas Software Xlib Engine Support])])
131 131
132PKG_CHECK_EXISTS([evas-xrender-x11 >= 1.0.0], [AC_DEFINE(HAVE_EVAS_XRENDER_X11, 1, [Evas Software Xlib Engine Support])]) 132PKG_CHECK_EXISTS([evas-xrender-x11 >= 1.2.0], [AC_DEFINE(HAVE_EVAS_XRENDER_X11, 1, [Evas Software Xlib Engine Support])])
133 133
134PKG_CHECK_EXISTS([evas-opengl-x11 >= 1.0.0], [AC_DEFINE(HAVE_EVAS_OPENGL_X11, 1, [Evas OpenGL Xlib Engine Support])]) 134PKG_CHECK_EXISTS([evas-opengl-x11 >= 1.2.0], [AC_DEFINE(HAVE_EVAS_OPENGL_X11, 1, [Evas OpenGL Xlib Engine Support])])
135 135
136PKG_CHECK_EXISTS([evas-fb >= 1.0.0], [AC_DEFINE(HAVE_EVAS_FB, 1, [Evas Framebuffer Engine Support])]) 136PKG_CHECK_EXISTS([evas-fb >= 1.2.0], [AC_DEFINE(HAVE_EVAS_FB, 1, [Evas Framebuffer Engine Support])])
137 137
138EFL_EDJE_EXTERNAL([have_edje_external="yes"], [have_edje_external="no"]) 138EFL_EDJE_EXTERNAL([have_edje_external="yes"], [have_edje_external="no"])
139 139
@@ -241,11 +241,11 @@ AC_ARG_ENABLE([ecore-x],
241 241
242if test "x$want_ecore_x" != "xno"; then 242if test "x$want_ecore_x" != "xno"; then
243 PKG_CHECK_MODULES([ECORE_X], 243 PKG_CHECK_MODULES([ECORE_X],
244 [ecore-x >= 1.0.0], 244 [ecore-x >= 1.2.0],
245 [ 245 [
246 AC_DEFINE(HAVE_ECORE_X, 1, [X11 support for Ecore]) 246 AC_DEFINE(HAVE_ECORE_X, 1, [X11 support for Ecore])
247 have_ecore_x="yes" 247 have_ecore_x="yes"
248 requirement_elm="ecore-x >= 1.0.0 ${requirement_elm}" 248 requirement_elm="ecore-x >= 1.2.0 ${requirement_elm}"
249 ], 249 ],
250 [have_ecore_x="no"] 250 [have_ecore_x="no"]
251 ) 251 )