aboutsummaryrefslogtreecommitdiffstats
path: root/m4
diff options
context:
space:
mode:
authorDaniel Kolesa <quaker66@gmail.com>2014-01-17 19:07:59 +0000
committerDaniel Kolesa <quaker66@gmail.com>2014-01-17 19:07:59 +0000
commit6db16915951af61d28f62f4de7c14c76e4303f18 (patch)
tree3b6560632d39eab69b974fc794cb9a9d269c5336 /m4
parentEvas cserve2: Fix invalid memory access (diff)
downloadefl-6db16915951af61d28f62f4de7c14c76e4303f18.tar.gz
edje: use luajit by default, if you want lua use --enable-lua-old
Diffstat (limited to 'm4')
-rw-r--r--m4/efl_lua_old.m4 (renamed from m4/efl_lua.m4)5
1 files changed, 3 insertions, 2 deletions
diff --git a/m4/efl_lua.m4 b/m4/efl_lua_old.m4
index b66ad0c7e8..ff8a33a4bb 100644
--- a/m4/efl_lua.m4
+++ b/m4/efl_lua_old.m4
@@ -1,8 +1,9 @@
-dnl EFL_CHECK_LUA(EFL)
+dnl EFL_CHECK_LUA_OLD(EFL)
dnl checks for lua 5.1 or 5.2 in pkg-config (multiple names) and -llua directly
dnl will call EFL_ADD_LIBS() or EFL_DEPEND_PKG() as required.
dnl this is a strict call and will abort if lua is not found
-AC_DEFUN([EFL_CHECK_LUA],
+dnl keep in mind that this is only executed if --enable-lua-old is set
+AC_DEFUN([EFL_CHECK_LUA_OLD],
[dnl
requirement_lua=""
PKG_CHECK_EXISTS([lua >= 5.1.0], [requirement_lua="lua >= 5.1.0"],