summaryrefslogtreecommitdiff
path: root/src/lib/elementary/elm_widget_index.h
diff options
context:
space:
mode:
authorJean-Philippe Andre <jp.andre@samsung.com>2017-11-01 15:16:30 +0900
committerJean-Philippe Andre <jp.andre@samsung.com>2017-11-01 21:23:31 +0900
commit824792f09d8c824d628cde95a1078b712da5db03 (patch)
treeb7d73bf4e1c6608ec1e6abc3360abb3825a54461 /src/lib/elementary/elm_widget_index.h
parentf851fa511e5b4fabac2002185b426445fc6ae208 (diff)
elm: Major cleanup of EO files
This prevents legacy EO classes from being exposed through .eo.h headers or .eo in share/eolian/includes. Also removes a slew of useless xxx_eo.h intermediate headers. Notes: - elm_systray has no proper API: it's not clear if the EO API should be released (in which case it needs to be renamed to efl_something) and there is no legacy API to create a systray object. - Some files have been placed in a "FIXME" section, as I believe they are necessary within EO land, but at the same time still don't conform to the interfaces (eg. name starts with elm_). - elm_interface_scrollable is required by photocam. This means photocam needs to be adapted to fit the EO scroller API (still to be completed, I believe). Bugs: - This breaks most C++ examples. I KNOW. And I'm working on it. Ref T5301
Diffstat (limited to 'src/lib/elementary/elm_widget_index.h')
-rw-r--r--src/lib/elementary/elm_widget_index.h3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/lib/elementary/elm_widget_index.h b/src/lib/elementary/elm_widget_index.h
index af6cf37..1b6c1a3 100644
--- a/src/lib/elementary/elm_widget_index.h
+++ b/src/lib/elementary/elm_widget_index.h
@@ -3,6 +3,9 @@
3 3
4#include "Elementary.h" 4#include "Elementary.h"
5 5
6#include "elm_index_item.eo.h"
7#include "elm_index.eo.h"
8
6/* DO NOT USE THIS HEADER UNLESS YOU ARE PREPARED FOR BREAKING OF YOUR 9/* DO NOT USE THIS HEADER UNLESS YOU ARE PREPARED FOR BREAKING OF YOUR
7 * CODE. THIS IS ELEMENTARY'S INTERNAL WIDGET API (for now) AND IS NOT 10 * CODE. THIS IS ELEMENTARY'S INTERNAL WIDGET API (for now) AND IS NOT
8 * FINAL. CALL elm_widget_api_check(ELM_INTERNAL_API_VERSION) TO CHECK 11 * FINAL. CALL elm_widget_api_check(ELM_INTERNAL_API_VERSION) TO CHECK