summaryrefslogtreecommitdiff
path: root/src/lib
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-12-18 11:16:38 +0000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2020-12-18 11:28:10 +0000
commit00f5eed1d2390d204c83a2cb78a37531f6bbe49c (patch)
treeb3c95338bd7d90127e904ac972859779a15b0e64 /src/lib
parent5f3152a30b6d53def24b85a1b76c75c82edc3c08 (diff)
evas - avif - fix for 0.8.2 libavif that broke api
also require 0.8.2 ... as well - no point trying to support older versions forever and this is still experimental. fixes T8844 @fix
Diffstat (limited to 'src/lib')
-rw-r--r--src/lib/evas/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/lib/evas/meson.build b/src/lib/evas/meson.build
index 883a959aa2..8dcfd98713 100644
--- a/src/lib/evas/meson.build
+++ b/src/lib/evas/meson.build
@@ -10,7 +10,7 @@ giflib = cc.find_library('gif')
10webp = dependency('libwebp', version: ['>=0.5.0'], required: get_option('evas-loaders-disabler').contains('webp') == false) 10webp = dependency('libwebp', version: ['>=0.5.0'], required: get_option('evas-loaders-disabler').contains('webp') == false)
11webpdemux = dependency('libwebpdemux', version: ['>=0.5.0'], required: get_option('evas-loaders-disabler').contains('webp') == false) 11webpdemux = dependency('libwebpdemux', version: ['>=0.5.0'], required: get_option('evas-loaders-disabler').contains('webp') == false)
12libopenjp2 = dependency('libopenjp2', required: get_option('evas-loaders-disabler').contains('jp2k') == false) 12libopenjp2 = dependency('libopenjp2', required: get_option('evas-loaders-disabler').contains('jp2k') == false)
13libavif = dependency('libavif', required: get_option('evas-loaders-disabler').contains('avif') == false) 13libavif = dependency('libavif', required: get_option('evas-loaders-disabler').contains('avif') == false, version: '>= 0.8.2')
14 14
15evas_image_loaders_file = [ 15evas_image_loaders_file = [
16 ['avif', 'shared', [libavif]], 16 ['avif', 'shared', [libavif]],