summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
-rw-r--r--m4/evas_check_engine.m44
2 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e8c44e0402..6e32846fb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1026,7 +1026,7 @@ AC_ARG_ENABLE([wayland],
1026 [want_wayland="no"]) 1026 [want_wayland="no"])
1027 1027
1028if test "${want_wayland}" = "yes"; then 1028if test "${want_wayland}" = "yes"; then
1029 EFL_PKG_CHECK_STRICT([wayland-client]) 1029 EFL_PKG_CHECK_STRICT([wayland-client >= 1.3.0])
1030fi 1030fi
1031 1031
1032# Fb 1032# Fb
@@ -2426,7 +2426,7 @@ EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eo])
2426EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eina]) 2426EFL_INTERNAL_DEPEND_PKG([ECORE_WAYLAND], [eina])
2427 2427
2428EFL_DEPEND_PKG([ECORE_WAYLAND], [WAYLAND], 2428EFL_DEPEND_PKG([ECORE_WAYLAND], [WAYLAND],
2429 [wayland-client >= 1.2.0 wayland-cursor >= 1.2.0 xkbcommon >= 0.3.0]) 2429 [wayland-client >= 1.3.0 wayland-cursor >= 1.3.0 xkbcommon >= 0.3.0])
2430 2430
2431EFL_EVAL_PKGS([ECORE_WAYLAND]) 2431EFL_EVAL_PKGS([ECORE_WAYLAND])
2432 2432
diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4
index 1cc11bb510..3fd4890dd5 100644
--- a/m4/evas_check_engine.m4
+++ b/m4/evas_check_engine.m4
@@ -519,7 +519,7 @@ have_dep="no"
519evas_engine_[]$1[]_cflags="" 519evas_engine_[]$1[]_cflags=""
520evas_engine_[]$1[]_libs="" 520evas_engine_[]$1[]_libs=""
521 521
522PKG_CHECK_EXISTS([wayland-client >= 1.2.0], 522PKG_CHECK_EXISTS([wayland-client >= 1.3.0],
523 [ 523 [
524 have_dep="yes" 524 have_dep="yes"
525 requirement="wayland-client" 525 requirement="wayland-client"
@@ -560,7 +560,7 @@ else
560 gl_library="gl" 560 gl_library="gl"
561fi 561fi
562 562
563PKG_CHECK_EXISTS([egl >= 7.10 ${gl_library} wayland-client >= 1.2.0 wayland-egl >= 9.2.0], 563PKG_CHECK_EXISTS([egl >= 7.10 ${gl_library} wayland-client >= 1.3.0 wayland-egl >= 9.2.0],
564 [ 564 [
565 have_dep="yes" 565 have_dep="yes"
566 requirement="egl >= 7.10 ${gl_library} wayland-client wayland-egl" 566 requirement="egl >= 7.10 ${gl_library} wayland-client wayland-egl"