summaryrefslogtreecommitdiff
path: root/m4/efl_lua_old.m4
diff options
context:
space:
mode:
Diffstat (limited to 'm4/efl_lua_old.m4')
-rw-r--r--m4/efl_lua_old.m436
1 files changed, 0 insertions, 36 deletions
diff --git a/m4/efl_lua_old.m4 b/m4/efl_lua_old.m4
deleted file mode 100644
index 537a6f3..0000000
--- a/m4/efl_lua_old.m4
+++ /dev/null
@@ -1,36 +0,0 @@
1dnl EFL_CHECK_LUA_OLD(EFL)
2dnl checks for lua 5.1 or 5.2 in pkg-config (multiple names) and -llua directly
3dnl will call EFL_ADD_LIBS() or EFL_DEPEND_PKG() as required.
4dnl this is a strict call and will abort if lua is not found
5dnl keep in mind that this is only executed if --enable-lua-old is set
6AC_DEFUN([EFL_CHECK_LUA_OLD],
7[dnl
8requirement_lua=""
9PKG_CHECK_EXISTS([lua >= 5.1.0], [requirement_lua="lua >= 5.1.0"],
10 [PKG_CHECK_EXISTS([lua5.1 >= 5.1.0], [requirement_lua="lua5.1 >= 5.1.0"],
11 [PKG_CHECK_EXISTS([lua-5.1 >= 5.1.0], [requirement_lua="lua-5.1 >= 5.1.0"],
12 [PKG_CHECK_EXISTS([lua51 >= 5.1.0], [requirement_lua="lua51 >= 5.1.0"],
13 [PKG_CHECK_EXISTS([lua5.2 >= 5.2.0], [requirement_lua="lua5.2 >= 5.2.0"],
14 [PKG_CHECK_EXISTS([lua-5.2 >= 5.2.0], [requirement_lua="lua-5.2 >= 5.2.0"],
15 [PKG_CHECK_EXISTS([lua52 >= 5.2.0], [requirement_lua="lua52 >= 5.2.0"])])])])])])])
16
17if test "x${requirement_lua}" = "x"; then
18 AC_MSG_CHECKING([whether lua_newstate() is in liblua])
19 AC_CHECK_LIB([lua], [lua_newstate],
20 [have_lua="yes"
21 EFL_ADD_LIBS([$1], [-llua])],
22 [have_lua="no"])
23 AC_MSG_RESULT([${have_lua}])
24 if test "${have_lua}" = "no"; then
25 AC_MSG_ERROR([Missing lua 5.1 or 5.2 support])
26 fi
27else
28 req_found="no"
29 EFL_DEPEND_PKG([$1], [LUA], [${requirement_lua}],
30 [ req_found="yes" ],
31 [ req_found="no" ])
32 if test "x${req_found}" = "xyes"; then
33 PKG_CHECK_MODULES([$1]_LUA, [${requirement_lua}])
34 fi
35fi
36])