summaryrefslogtreecommitdiff
path: root/m4
diff options
context:
space:
mode:
Diffstat (limited to 'm4')
-rw-r--r--m4/evas_check_engine.m413
1 files changed, 10 insertions, 3 deletions
diff --git a/m4/evas_check_engine.m4 b/m4/evas_check_engine.m4
index 448a210592..4789d4b9f0 100644
--- a/m4/evas_check_engine.m4
+++ b/m4/evas_check_engine.m4
@@ -597,16 +597,23 @@ AC_DEFUN([EVAS_CHECK_ENGINE_DEP_DRM],
597[ 597[
598 598
599requirement="" 599requirement=""
600have_dep="yes" 600have_dep="no"
601have_hw_dep="no" 601have_hw_dep="no"
602evas_engine_[]$1[]_cflags="" 602evas_engine_[]$1[]_cflags=""
603evas_engine_[]$1[]_libs="" 603evas_engine_[]$1[]_libs=""
604 604
605PKG_CHECK_EXISTS([libdrm],
606 [
607 have_dep="yes"
608 requirement="libdrm"
609 ], [have_dep="no"])
610
605if test "x${have_dep}" = "xyes" ; then 611if test "x${have_dep}" = "xyes" ; then
606 if test "x$3" = "xstatic" ; then 612 if test "x$3" = "xstatic" ; then
607 requirements_pc_evas="${requirement} ${requirements_pc_evas}" 613 requirements_pc_evas="${requirement} ${requirements_pc_evas}"
608 requirements_pc_deps_evas="${requirement} ${requirements_pc_deps_evas}" 614 requirements_pc_deps_evas="${requirement} ${requirements_pc_deps_evas}"
609 else 615 else
616 PKG_CHECK_MODULES([DRM], [${requirement}])
610 evas_engine_[]$1[]_cflags="${DRM_CFLAGS}" 617 evas_engine_[]$1[]_cflags="${DRM_CFLAGS}"
611 evas_engine_[]$1[]_libs="${DRM_LIBS}" 618 evas_engine_[]$1[]_libs="${DRM_LIBS}"
612 fi 619 fi
@@ -636,10 +643,10 @@ else
636 AC_MSG_ERROR([We currently do not support GL DRM without OpenGL ES. Please consider OpenGL ES if you want to use it.]) 643 AC_MSG_ERROR([We currently do not support GL DRM without OpenGL ES. Please consider OpenGL ES if you want to use it.])
637fi 644fi
638 645
639PKG_CHECK_EXISTS([egl ${gl_library} gbm wayland-client >= REQUIRED_WAYLAND_VERSION], 646PKG_CHECK_EXISTS([egl ${gl_library} libdrm gbm wayland-client >= REQUIRED_WAYLAND_VERSION],
640 [ 647 [
641 have_dep="yes" 648 have_dep="yes"
642 requirement="egl ${gl_library} gbm wayland-client >= REQUIRED_WAYLAND_VERSION" 649 requirement="egl ${gl_library} libdrm gbm wayland-client >= REQUIRED_WAYLAND_VERSION"
643 ], 650 ],
644 [have_dep="no"]) 651 [have_dep="no"])
645 652