summaryrefslogtreecommitdiff
path: root/src/lib/efl/interfaces/efl_ui_range_display.eo
blob: ca9d2c1e1b4a86d6c1ee046c17b28a0066a47c86 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
interface @beta Efl.Ui.Range_Display
{
   [[Interface that contains properties regarding the displaying of a range.]]
   eo_prefix: efl_ui_range;
   methods {
      @property range_value {
         [[Control the range value (in percentage) on a given range widget

           Use this call to set range levels.

           Note: If you pass a value out of the specified interval for
           $val, it will be interpreted as the closest of the boundary
           values in the interval.]]
         set {
         }
         get {
         }
         values {
            val: double; [[The range value (must be between $0.0 and 1.0)]]
         }
      }
      @property range_min_max {
         set {
            [[Set the minimum and maximum values for given range widget.

              Define the allowed range of values to be selected by the user.

              If actual value is less than $min, it will be updated to $min.
              If it is bigger then $max, will be updated to $max. The actual value
              can be obtained with @Efl.Ui.Range_Display.range_value.get

              The minimum and maximum values may be different for each class.

              Warning: maximum must be greater than minimum, otherwise behavior
              is undefined.
            ]]
         }
         get {
            [[Get the minimum and maximum values of the given range widget.

              Note: If only one value is needed, the other pointer can be passed
              as $null.
            ]]
         }
         values {
            min: double; [[The minimum value.]]
            max: double; [[The maximum value.]]
         }
      }
   }
}