summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac8
-rw-r--r--elementary.pc.in2
2 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 19cfbaaef..2d2514752 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,14 +143,6 @@ EFL_CXX_COMPILE_STDCXX_11([ext])
143# pkg-config 143# pkg-config
144PKG_PROG_PKG_CONFIG 144PKG_PROG_PKG_CONFIG
145 145
146# Check whether pkg-config supports Requires.private
147if $PKG_CONFIG --atleast-pkgconfig-version 0.22; then
148 pkgconfig_requires_private="Requires.private"
149else
150 pkgconfig_requires_private="Requires"
151fi
152AC_SUBST([pkgconfig_requires_private])
153
154# gettext 146# gettext
155m4_ifdef([AM_GNU_GETTEXT_VERSION], [ 147m4_ifdef([AM_GNU_GETTEXT_VERSION], [
156AM_GNU_GETTEXT_VERSION([0.18]) 148AM_GNU_GETTEXT_VERSION([0.18])
diff --git a/elementary.pc.in b/elementary.pc.in
index 3c880fdff..4288f20f1 100644
--- a/elementary.pc.in
+++ b/elementary.pc.in
@@ -11,7 +11,7 @@ eolian_flags=-I${eoincludedir}/elementary-@VMAJ@
11 11
12Name: elementary 12Name: elementary
13Description: Mobile device touchscreen widget library 13Description: Mobile device touchscreen widget library
14@pkgconfig_requires_private@: @requirement_elm@ 14Requires.private: @requirement_elm@
15Version: @VERSION@ 15Version: @VERSION@
16Libs: -L${libdir} -lelementary @my_libs@ @ELEMENTARY_LIBS@ @ELEMENTARY_WEB_LIBS@ @ELEMENTARY_EMAP_LIBS@ 16Libs: -L${libdir} -lelementary @my_libs@ @ELEMENTARY_LIBS@ @ELEMENTARY_WEB_LIBS@ @ELEMENTARY_EMAP_LIBS@
17Cflags: -I${includedir}/elementary-@VMAJ@ 17Cflags: -I${includedir}/elementary-@VMAJ@