aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac (follow)
Commit message (Collapse)AuthorAgeFilesLines
* 21.11 ReleaseSimon Lees2017-11-031-2/+2
|
* 21.10 ReleaseSimon Lees2017-09-261-2/+2
|
* 21.9 ReleaseSimon Lees2017-08-041-2/+2
|
* 21.8 ReleaseSimon Lees2017-05-181-2/+2
|
* 21.7 ReleaseSimon Lees2017-03-071-2/+2
|
* 21.6 ReleaseSimon Lees2017-02-151-2/+2
|
* 10_typo_restore_LDFLAGS.diff: Fix typo in configure.ac (upstream), causing ↵Andreas Metzler2017-02-031-1/+1
| | | | | | | | | | | | empty LDFLAGS. Summary: typo spotted while packaging E 0.21.5 for Debian experimental Reviewers: zmike! Subscribers: cedric Differential Revision: https://phab.enlightenment.org/D4507
* 21.5 ReleaseSimon Lees2016-12-081-2/+2
|
* 21.4 ReleaseSimon Lees2016-11-291-2/+2
|
* actually check if PIE is supported for SUIDAlexander Pyhalov2016-11-181-4/+22
| | | | fix T4479
* 21.3 ReleaseSimon Lees2016-10-071-2/+2
|
* Fix xwayland binary location detectionDerek Foreman2016-10-041-5/+9
| | | | | We were trying to find it with pkg-config and failing, try AC_PATH_PROG instead
* configure.ac: wayland only build fixRomain Naour2016-10-041-1/+1
| | | | | | | | | | | | | When only wayland is enabled, the build system is still looking for ecore-x. When the following test is always true since have_wayland_only has been initialed to "no". if test "x${have_wayland_only}" != "xyes"; then PKG_CHECK_MODULES([ECORE_X], [ecore-x >= ${efl_version}]) Use e_cv_want_wayland_only instead. Signed-off-by: Romain Naour <romain.naour@gmail.com>
* 21.2 ReleaseSimon Lees2016-08-211-2/+2
|
* bump efl wayland req to 1.18 now that it's outMike Blumenkrantz2016-08-171-1/+1
|
* 21.1 ReleaseSimon Lees2016-07-201-1/+1
|
* 21.0 releaseMike Blumenkrantz2016-06-301-4/+4
|
* unset release modeMike Blumenkrantz2016-06-021-5/+5
|
* 21.0-rc releaseMike Blumenkrantz2016-06-021-5/+5
|
* Bump wayland version requirement to 1.11.0Derek Foreman2016-06-011-1/+1
| | | | | 1.11.0 includes fixes we need to prevent clients from crashing E by resizing shared memory pools while our async renderer is running.
* port enlightenment to use drm2devs/devilhorns/ecore_drm2Chris Michael2016-05-271-5/+13
| | | | Signed-off-by: Chris Michael <cpmichael@osg.samsung.com>
* add checks for building with Ecore_Drm2 supportChris Michael2016-05-251-1/+10
| | | | Signed-off-by: Chris Michael <cpmichael@osg.samsung.com>
* allow building shot+xkbswitch modules without ecore-xMike Blumenkrantz2016-05-161-2/+2
| | | | these work with wayland now, hooray
* add configure flag for xwayland binaryMike Blumenkrantz2016-05-061-2/+2
|
* unset release modeMike Blumenkrantz2016-04-261-5/+5
|
* 21.0-beta releaseMike Blumenkrantz2016-04-261-5/+5
|
* Revert "WIP"Eduardo Lima (Etrunko)2016-04-251-1/+1
| | | | This reverts commit 9959f6772337534e5db251f810fc66462c1a9f03.
* WIPEduardo Lima (Etrunko)2016-04-251-1/+1
| | | | Signed-off-by: Eduardo Lima (Etrunko) <eduardo.lima@intel.com>
* unset release modeMike Blumenkrantz2016-04-121-5/+5
|
* 21.0-alpha releaseMike Blumenkrantz2016-04-121-5/+5
|
* reduce efl version req to 1.17.0, make new gadget stuff 1.7.99+ at runtimeMike Blumenkrantz2016-04-111-1/+1
|
* wayland: Bump ecore-wl2 dependency to 1.17.99Derek Foreman2016-04-081-1/+1
|
* disable xwayland module if exe cannot be found during configureMike Blumenkrantz2016-04-041-0/+3
| | | | | | should probably make this a --flag at some point fix T3415
* remove library checks for a number of modules along with useless definesMike Blumenkrantz2016-03-111-91/+24
| | | | | most of these date back from before efl was a unified tree or enlightenment itself could be optionally built with things like dbus support
* require >= efl 1.17.1 for gadget theme stuffMike Blumenkrantz2016-03-041-1/+1
|
* add new time module with clock gadgetsMike Blumenkrantz2016-03-041-0/+2
| | | | | this is the successor to the clock module/gadget. it uses separate config files and theme groups from the "clock" module.
* add new wireless module/gadgetMike Blumenkrantz2016-03-041-0/+2
| | | | | this is the successor to the connman module/gadget. it does not use or depend on econnman.
* Bump wayland version requirementDerek Foreman2016-02-181-1/+1
| | | | We need 1.10 for the shm pool referencing api
* require efl 1.17Mike Blumenkrantz2016-02-041-1/+1
|
* enable drm e_alert during configure only if drm support is enabledMike Blumenkrantz2016-02-011-5/+7
|
* Fix build break for non-wayland buildsChris Michael2016-01-141-11/+19
| | | | | | | | | This patch fixes an issue where implementing WBOD for wayland would always (previously) require ecore-drm to build. We fix this by adjusting the enlightenment_alert requirements based on if we are building with wayland support or not. Signed-off-by: Chris Michael <cpmichael@osg.samsung.com>
* Update dependencies for enlightenment_alert binaryChris Michael2016-01-131-0/+3
| | | | Signed-off-by: Chris Michael <cpmichael@osg.samsung.com>
* configure.ac: Remove ecore-x from wayland only build.Seunghun Lee2016-01-061-1/+0
| | | | | | | | Reviewers: devilhorns, zmike Subscribers: cedric Differential Revision: https://phab.enlightenment.org/D3538
* Reenable building wl_wl moduleChris Michael2016-01-051-1/+1
| | | | Signed-off-by: Chris Michael <cpmichael@osg.samsung.com>
* disable building wl_wl module for nowChris Michael2015-12-091-1/+1
| | | | Signed-off-by: Chris Michael <cp.michael@samsung.com>
* Make configure check for Ecore_Wl2 libraryChris Michael2015-12-091-2/+2
| | | | Signed-off-by: Chris Michael <cp.michael@samsung.com>
* bump versionMike Blumenkrantz2015-11-301-3/+3
|
* unset release modeMike Blumenkrantz2015-11-301-4/+4
| | | | feature freeze is over, have fun
* e20 releaseMike Blumenkrantz2015-11-301-4/+4
|
* unset release modeMike Blumenkrantz2015-11-111-5/+5
|