You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 

55 lines
1.4 KiB

m4_define([pkg_version], [0.9])
#m4_define([pkg_revision], [000])
m4_define([pkg_version], m4_ifdef([pkg_revision], [pkg_version.pkg_revision], [pkg_version]))
m4_define([rpm_revision], m4_ifdef([pkg_revision], ["0.%(date '+%y%m%d')"], [1]))
AC_INIT([e16-keyedit], [pkg_version], [enlightenment-devel@lists.sourceforge.net])
AM_INIT_AUTOMAKE([foreign dist-xz])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_MACRO_DIR([m4])
AC_SUBST(E_RPM_REVISION, [rpm_revision])
AC_USE_SYSTEM_EXTENSIONS
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
PKG_PROG_PKG_CONFIG
dnl Checks for libraries.
AC_ARG_WITH(gtk,
[ --with-gtk Select GTK version to use (auto/gtk2/gtk3) @<:@default=auto@:>@],,
with_gtk=auto)
test_gtk="$with_gtk"
if test "x$with_gtk" = "xauto" ; then test_gtk="gtk2"; fi
if test "x$test_gtk" = "xgtk2" ; then
AC_MSG_CHECKING([for GTK2]);
pkg_modules="gtk+-2.0 >= 2.0.0"
PKG_CHECK_MODULES(GTK, [$pkg_modules],,
[if test "x$with_gtk" = "xauto" ; then test_gtk="gtk3"; fi])
fi
if test "x$test_gtk" = "xgtk3" ; then
AC_MSG_CHECKING([for GTK3]);
pkg_modules="gtk+-3.0 >= 3.0.0"
PKG_CHECK_MODULES(GTK, [$pkg_modules])
fi
if test "x$GTK_CFLAGS" = "x" ; then
AC_MSG_ERROR([GTK 2 or 3 is required.])
fi
dnl Checks for header files.
AC_PATH_X
AC_HEADER_STDC
AC_CHECK_HEADERS(unistd.h)
EC_C_WARNINGS()
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES(Makefile e16-keyedit.spec)
AC_OUTPUT