Meson: explicit efl require and link

master
Davide Andreoli 3 years ago
parent 7c2a320609
commit a5aa37c726
  1. 4
      meson.build
  2. 2
      src/meson.build

@ -9,6 +9,10 @@ project('edgar', 'c',
# NOTE: meson 53 needed for the 'embed' param of py3.dependency()
#### EFL ####
dep_efl = dependency('efl', version: '>= 1.24')
#### Enlightenemnt ####
dep_e = dependency('enlightenment', version: '>= 0.23.99')
e_modules_dir = dep_e.get_pkgconfig_variable('modules')

@ -4,7 +4,7 @@ module = shared_module(
'e_mod_main.c',
'e_mod_edgar.c',
dependencies : [dep_e, dep_py3, dep_dl],
dependencies : [dep_efl, dep_e, dep_py3, dep_dl],
install_dir: lib_install_dir,
include_directories: config_dir,
install: true,

Loading…
Cancel
Save