python-efl/setup.py

458 lines
13 KiB
Python
Raw Normal View History

Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
#! /usr/bin/env python
# encoding: utf-8
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
import os
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
import sys
import subprocess
from distutils.core import setup, Command
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
from distutils.extension import Extension
from distutils.version import StrictVersion, LooseVersion
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
script_path = os.path.dirname(os.path.abspath(__file__))
# python-efl version
VERSION = "1.10"
RELEASE = "1.9.99"
# Add git commit count for dev builds
if RELEASE.split(".")[2] == "99":
call = subprocess.Popen(
["git", "log", "--oneline"], stdout=subprocess.PIPE)
out, err = call.communicate()
log = out.decode("utf-8").strip()
if log:
ver = log.count("\n")
RELEASE += "a" + str(ver)
# dependencies
CYTHON_MIN_VERSION = "0.19"
EFL_MIN_VERSION = "1.9.99"
ELM_MIN_VERSION = "1.9.99"
2013-12-09 23:55:46 -08:00
# XXX: Force default visibility. See phab T504
if os.getenv("CFLAGS") is not None and "-fvisibility=" in os.environ["CFLAGS"]:
os.environ["CFLAGS"] += " -fvisibility=default"
# === Sphinx ===
try:
from sphinx.setup_command import BuildDoc
except ImportError:
class BuildDoc(Command):
2014-04-29 02:20:33 -07:00
description = \
"build documentation using sphinx, that must be installed."
user_options = []
2014-04-29 02:20:33 -07:00
def initialize_options(self):
pass
def finalize_options(self):
pass
def run(self):
print("Error: sphinx not found")
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
# === pkg-config ===
def pkg_config(name, require, min_vers=None):
try:
sys.stdout.write("Checking for " + name + ": ")
call = subprocess.Popen(
["pkg-config", "--modversion", require], stdout=subprocess.PIPE)
out, err = call.communicate()
ver = out.decode("utf-8").strip()
if min_vers is not None:
assert 0 == subprocess.call(
["pkg-config", "--atleast-version", min_vers, require])
call = subprocess.Popen(
["pkg-config", "--cflags", require], stdout=subprocess.PIPE)
out, err = call.communicate()
cflags = out.decode("utf-8").split()
call = subprocess.Popen(
["pkg-config", "--libs", require], stdout=subprocess.PIPE)
out, err = call.communicate()
libs = out.decode("utf-8").split()
sys.stdout.write("OK, found " + ver + "\n")
cflags = list(set(cflags))
return (cflags, libs)
except (OSError, subprocess.CalledProcessError):
raise SystemExit("Did not find " + name + " with 'pkg-config'.")
except (AssertionError):
2014-04-29 02:20:33 -07:00
raise SystemExit(
name + " version mismatch. Found: " + ver + " Needed: " + min_vers
)
# use cython or pre-generated c files
if os.getenv("USE_CYTHON") or \
not os.path.exists(
os.path.join(script_path, "efl", "eo", "efl.eo.c")
):
module_suffix = ".pyx"
try:
from Cython.Distutils import build_ext
from Cython.Build import cythonize
import Cython.Compiler.Options
except ImportError:
2014-04-29 02:20:33 -07:00
raise SystemExit(
"Requires Cython >= %s (http://cython.org/)" % CYTHON_MIN_VERSION
)
try:
try:
2014-04-29 02:20:33 -07:00
assert StrictVersion(Cython.__version__) >= \
StrictVersion(CYTHON_MIN_VERSION)
except ValueError:
2014-04-29 02:20:33 -07:00
print(
"Your Cython version string (%s) is weird. We'll attempt to "
"check that it's higher than the minimum required: %s, but "
"this is unreliable.\n"
"If you run into any problems during or after installation it "
"may be caused by version of Cython that's too old." % (
Cython.__version__, CYTHON_MIN_VERSION
)
2014-04-29 02:20:33 -07:00
)
assert LooseVersion(Cython.__version__) >= \
LooseVersion(CYTHON_MIN_VERSION)
except AssertionError:
2014-04-29 02:20:33 -07:00
raise SystemExit(
"Requires Cython >= %s (http://cython.org/)" % CYTHON_MIN_VERSION
)
2014-04-29 02:20:33 -07:00
Cython.Compiler.Options.fast_fail = True # Stop compilation on first error
Cython.Compiler.Options.annotate = False # Generates HTML files with
# annotated source
Cython.Compiler.Options.docstrings = True # Set to False to disable
# docstrings
else:
module_suffix = ".c"
from distutils.command.build_ext import build_ext
2014-04-29 02:20:33 -07:00
def cythonize(modules, *args, **kwargs):
return modules
class CleanGenerated(Command):
description = "Clean C and html files generated by Cython"
user_options = []
2014-04-29 02:20:33 -07:00
def initialize_options(self):
pass
def finalize_options(self):
pass
def run(self):
2014-04-29 02:20:33 -07:00
for lib in ("eo", "evas", "ecore", "edje", "edje/edit", "emotion",
"elementary", "utils"):
for root, dirs, files in \
os.walk(os.path.join(script_path, "efl", lib)):
for f in files:
if f.endswith(".c") or f.endswith(".html"):
path = os.path.join(root, f)
os.remove(path)
2014-04-29 02:20:33 -07:00
dbus_ml_path = os.path.join(
script_path, "efl", "dbus_mainloop", "dbus_mainloop.c")
if os.path.exists(dbus_ml_path):
os.remove(dbus_ml_path)
modules = []
packages = ["efl"]
package_dirs = {}
if set(("build", "build_ext", "install", "bdist", "sdist")) & set(sys.argv):
# === Eina ===
eina_cflags, eina_libs = pkg_config('Eina', 'eina', EFL_MIN_VERSION)
# === Eo ===
eo_cflags, eo_libs = pkg_config('Eo', 'eo', EFL_MIN_VERSION)
2014-04-29 02:20:33 -07:00
eo_ext = Extension(
"eo", ["efl/eo/efl.eo" + module_suffix],
define_macros=[('EFL_BETA_API_SUPPORT', None)],
include_dirs=['include/'],
extra_compile_args=eo_cflags,
extra_link_args=eo_libs + eina_libs
)
modules.append(eo_ext)
# === Utilities ===
utils_ext = [
2014-04-29 02:20:33 -07:00
Extension(
"utils.deprecated", ["efl/utils/deprecated" + module_suffix],
include_dirs=['include/'],
extra_compile_args=eina_cflags,
extra_link_args=eina_libs
),
Extension(
"utils.conversions", ["efl/utils/conversions" + module_suffix],
include_dirs=['include/'],
extra_compile_args=eo_cflags,
extra_link_args=eo_libs + eina_libs,
),
Extension(
"utils.logger", ["efl/utils/logger" + module_suffix],
include_dirs=['include/'],
extra_compile_args=eina_cflags,
extra_link_args=eina_libs,
),
]
modules += utils_ext
packages.append("efl.utils")
# === Evas ===
evas_cflags, evas_libs = pkg_config('Evas', 'evas', EFL_MIN_VERSION)
2014-04-29 02:20:33 -07:00
evas_ext = Extension(
"evas", ["efl/evas/efl.evas" + module_suffix],
include_dirs=['include/'],
extra_compile_args=evas_cflags,
extra_link_args=evas_libs + eina_libs,
)
modules.append(evas_ext)
# compatibility
packages.append("evas")
package_dirs["evas"] = "compat/evas"
# === Ecore ===
ecore_cflags, ecore_libs = pkg_config('Ecore', 'ecore', EFL_MIN_VERSION)
2014-04-29 02:20:33 -07:00
ecore_file_cflags, ecore_file_libs = pkg_config(
'EcoreFile', 'ecore-file', EFL_MIN_VERSION)
ecore_ext = Extension(
"ecore", ["efl/ecore/efl.ecore" + module_suffix],
include_dirs=['include/'],
extra_compile_args=list(set(ecore_cflags + ecore_file_cflags)),
extra_link_args=ecore_libs + ecore_file_libs + eina_libs + evas_libs,
)
modules.append(ecore_ext)
# compatibility
packages.append("ecore")
package_dirs["ecore"] = "compat/ecore"
2014-04-11 08:12:49 -07:00
# === Ethumb ===
2014-04-29 02:20:33 -07:00
ethumb_cflags, ethumb_libs = pkg_config(
'Ethumb', 'ethumb', EFL_MIN_VERSION)
ethumb_ext = Extension(
"ethumb", ["efl/ethumb/efl.ethumb" + module_suffix],
include_dirs=['include/'],
extra_compile_args=ethumb_cflags,
extra_link_args=ethumb_libs + eina_libs,
)
2014-04-11 08:12:49 -07:00
modules.append(ethumb_ext)
2014-04-29 02:20:33 -07:00
ethumb_client_cflags, ethumb_client_libs = pkg_config(
'Ethumb_Client', 'ethumb_client', EFL_MIN_VERSION)
ethumb_client_ext = Extension(
"ethumb_client", ["efl/ethumb/efl.ethumb_client" + module_suffix],
include_dirs=['include/'],
extra_compile_args=ethumb_client_cflags,
extra_link_args=ethumb_client_libs + eina_libs,
)
2014-04-11 08:12:49 -07:00
modules.append(ethumb_client_ext)
# === Edje ===
edje_cflags, edje_libs = pkg_config('Edje', 'edje', EFL_MIN_VERSION)
2014-04-29 02:20:33 -07:00
edje_ext = Extension(
"edje", ["efl/edje/efl.edje" + module_suffix],
include_dirs=['include/'],
extra_compile_args=edje_cflags,
extra_link_args=edje_libs + eina_libs + evas_libs,
)
modules.append(edje_ext)
# compatibility
packages.append("edje")
package_dirs["edje"] = "compat/edje"
# --- Edje_Edit ---
2014-04-29 02:20:33 -07:00
edje_edit_ext = Extension(
"edje_edit", ["efl/edje/efl.edje_edit" + module_suffix],
define_macros=[('EDJE_EDIT_IS_UNSTABLE_AND_I_KNOW_ABOUT_IT', None)],
include_dirs=['include/'],
extra_compile_args=edje_cflags,
extra_link_args=edje_libs + eina_libs + evas_libs,
)
modules.append(edje_edit_ext)
# === Emotion ===
2014-04-29 02:20:33 -07:00
emotion_cflags, emotion_libs = pkg_config(
'Emotion', 'emotion', EFL_MIN_VERSION)
emotion_ext = Extension(
"emotion", ["efl/emotion/efl.emotion" + module_suffix],
include_dirs=['include/'],
extra_compile_args=emotion_cflags,
extra_link_args=emotion_libs +
eina_libs + evas_libs,
)
modules.append(emotion_ext)
# compatibility
packages.append("emotion")
package_dirs["emotion"] = "compat/emotion"
# === dbus mainloop integration ===
dbus_cflags, dbus_libs = pkg_config('DBus', 'dbus-python', "0.83.0")
2014-04-29 02:20:33 -07:00
dbus_ml_ext = Extension(
"dbus_mainloop",
["efl/dbus_mainloop/dbus_mainloop" + module_suffix,
"efl/dbus_mainloop/e_dbus.c"],
extra_compile_args=list(set(dbus_cflags + ecore_cflags)),
extra_link_args=dbus_libs + ecore_libs,
)
modules.append(dbus_ml_ext)
# compatibility
packages.append("e_dbus")
package_dirs["e_dbus"] = "compat/e_dbus"
# === Elementary ===
elm_mods = (
#"access",
"actionslider",
"background",
"box",
"bubble",
"button",
"calendar_elm",
"check",
"clock",
"colorselector",
"configuration",
"conformant",
"ctxpopup",
"datetime_elm",
"dayselector",
"diskselector",
"entry",
"fileselector_button",
"fileselector_entry",
"fileselector",
"flip",
"flipselector",
"frame",
"general",
"gengrid",
"genlist",
"gesture_layer",
#"glview",
"grid",
"hover",
"hoversel",
"icon",
"image",
"index",
"innerwindow",
"label",
"layout_class",
"layout",
"list",
"mapbuf",
"map",
"menu",
"multibuttonentry",
"naviframe",
"need",
"notify",
"object_item",
"object",
"panel",
"panes",
"photocam",
"photo",
"plug",
"popup",
"progressbar",
"radio",
"scroller",
"segment_control",
"separator",
"slider",
"slideshow",
"spinner",
#"store",
"table",
"theme",
"thumb",
"toolbar",
"transit",
"video",
"web",
"window",
)
2014-04-29 02:20:33 -07:00
elm_cflags, elm_libs = pkg_config(
'Elementary', 'elementary', ELM_MIN_VERSION)
for m in elm_mods:
2014-04-29 02:20:33 -07:00
e = Extension(
"elementary." + m,
["efl/elementary/" + m + module_suffix],
include_dirs=["include/"],
extra_compile_args=elm_cflags,
extra_link_args=elm_libs + eina_libs + evas_libs,
)
modules.append(e)
packages.append("efl.elementary")
# compatibility
packages.append("elementary")
package_dirs["elementary"] = "compat/elementary"
Put in a first, still wip, version of the python bindings in a merged tree. This is meant to be the 1.8 version of the wrappers and will include everything that now is in the python folder. Atm this include evas, ecore, edje, elementary and emotion (emotion still commented in the build couse it need some more testing). Eo is used as a base for all the objects that inherit from it in C, but in real nothing is used from Eo, it is used more like a container to share code between the libs. All the docs has been stripped out because we want to use the new sphinx style docs that Kay has done in his git repo. (Kay: please wait a little bit to include it, as working on the libs without docs is much more easy) The new wrappers include a new container module called efl and thus you can live with both the old and the new installation. This also means that you need to import the new modules as: "from efl import evas" (instead of the old "import evas") The idea here is that you can make your code works with both version doing something like: try: import evas except: from efl import evas ...like is done in the gtk bindings Some stuff has been leaved out on purpose, because was old stuff (like the hacked evas rotation stuff) or because was not working as expected (like all the ecore.evas.XXX modules). See the TODO.txt file for more info. Probably some stuff is out just because I missed them, let me know if you miss something. Improvements from the old version: - Py3 compatible (still some work to be done, but really only TODO, no problems to resolv) - Should also works on other platforms, like windoz (but not tested) - Unittests greatly improved, you can also run ALL tests at once - much more simpler :) I will contine the works in the next weeks and hope someone will help too. NOTE: I switched back to setup.py instead of autotools, because that is the right way to compile python stuff. So to build just use: python setup.py install or python3 setup.py install Enjoy davemds SVN revision: 83831
2013-02-11 14:32:50 -08:00
setup(
2014-04-29 02:20:33 -07:00
name="python-efl",
fullname="Python bindings for Enlightenment Foundation Libraries",
description="Python bindings for Enlightenment Foundation Libraries",
version=RELEASE,
author=(
"Gustavo Sverzut Barbieri, Simon Busch, Boris 'billiob' Faure, "
"Davide Andreoli, Fabiano Fidêncio, Bruno Dilly, Tiago Falcão, "
"Joost Albers, Kai Huuhko, Ulisses Furquim"
),
author_email="dave@gurumeditation.it, kai.huuhko@gmail.com",
maintainer="Kai Huuhko, Davide Andreoli",
maintainer_email="kai.huuhko@gmail.com, dave@gurumeditation.it",
contact="Enlightenment developer mailing list",
contact_email="enlightenment-devel@lists.sourceforge.net",
url="http://www.enlightenment.org",
license="GNU Lesser General Public License (LGPL)",
cmdclass={
'build_ext': build_ext,
'build_doc': BuildDoc,
'clean_generated_files': CleanGenerated
2014-04-29 02:20:33 -07:00
},
command_options={
'build_doc': {
'version': ('setup.py', VERSION),
'release': ('setup.py', RELEASE)
2014-04-29 02:20:33 -07:00
}
},
package_dir=package_dirs,
packages=packages,
ext_package="efl", # The prefix for ext modules/packages
ext_modules=cythonize(
modules,
include_path=["include"],
compiler_directives={
#"c_string_type": "unicode",
#"c_string_encoding": "utf-8",
"embedsignature": True,
}
),
)