fix autogetn.sh for terminology for gettext

so i've been having trouble building for the past while unless i git
clean our build files etc. - it turned out to be the autogen.sh, so
i'm using one that works from elm. :)
devs/discomfitor/cc
Carsten Haitzler 8 years ago
parent 9a4d16de2b
commit e3172d6796
  1. 36
      autogen.sh

@ -3,10 +3,38 @@
rm -rf autom4te.cache
rm -f aclocal.m4 ltmain.sh
autoreconf --symlink --install || exit 1
touch README
touch ABOUT-NLS
if [ -z "$NOCONFIGURE" ]; then
exec ./configure -C "$@"
echo "Running autopoint..." ; autopoint -f || :
echo "Running aclocal..." ; aclocal $ACLOCAL_FLAGS -I m4 || exit 1
echo "Running autoheader..." ; autoheader || exit 1
echo "Running autoconf..." ; autoconf || exit 1
echo "Running libtoolize..." ; (libtoolize --copy --automake || glibtoolize --automake) || exit 1
echo "Running automake..." ; automake --add-missing --copy --gnu || exit 1
W=0
rm -f config.cache-env.tmp
echo "OLD_PARM=\"$@\"" >> config.cache-env.tmp
echo "OLD_CFLAGS=\"$CFLAGS\"" >> config.cache-env.tmp
echo "OLD_PATH=\"$PATH\"" >> config.cache-env.tmp
echo "OLD_PKG_CONFIG_PATH=\"$PKG_CONFIG_PATH\"" >> config.cache-env.tmp
echo "OLD_LDFLAGS=\"$LDFLAGS\"" >> config.cache-env.tmp
cmp config.cache-env.tmp config.cache-env >> /dev/null
if [ $? -ne 0 ]; then
W=1;
fi
exit 0
if [ $W -ne 0 ]; then
echo "Cleaning configure cache...";
rm -f config.cache config.cache-env
mv config.cache-env.tmp config.cache-env
else
rm -f config.cache-env.tmp
fi
if [ -z "$NOCONFIGURE" ]; then
./configure -C "$@"
fi

Loading…
Cancel
Save