build: ensure we set ENABLE_LUA_OLD when using a lua interpreter

We missed to actually set the ENABLE_LUA_OLD. Ross run into some
problems with Lua 5.2 builds and we hope this fixes the issue for him.

Found and fixed by Marcel Hollerbach (only put in the system by me).

Fixes T8705
devs/zmike/buildtest
Stefan Schmidt 3 years ago
parent 8538130ba2
commit 9e6e805689
  1. 1
      meson.build

@ -267,6 +267,7 @@ luaold_interpreters = [
lua_pc_name = ''
if get_option('lua-interpreter') == 'lua'
config_h.set('ENABLE_LUA_OLD', '1')
foreach l : luaold_interpreters
lua = dependency(l[0], version: l[1], required:false)
lua_pc_name = l[0]

Loading…
Cancel
Save