summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaffaele <rafspiny@gmail.com>2020-01-23 15:49:09 -0800
committerwww-data <www-data@enlightenment.org>2020-01-23 15:49:09 -0800
commitfb87ef1644e82401bba03156b87a6595689e17d8 (patch)
treeb6944d94a53b7513656101d1cd6dacd1305b8314
parent4a20a8691204bdcc34602201264780031133f6bb (diff)
Wiki page ubuntu-start.md changed with summary [] by Raffaele
-rw-r--r--pages/docs/distros/ubuntu-start.md.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/pages/docs/distros/ubuntu-start.md.txt b/pages/docs/distros/ubuntu-start.md.txt
index 3f218b3ac..cc2d4ee4b 100644
--- a/pages/docs/distros/ubuntu-start.md.txt
+++ b/pages/docs/distros/ubuntu-start.md.txt
@@ -40,10 +40,10 @@ And then install EFL and its development libraries:
40sudo apt-get install libefl-dev 40sudo apt-get install libefl-dev
41``` 41```
42 42
43Ubuntu does not install by default the *gcc* compiler, so, before you can [compile any apps](#Compiling_EFL_Applications), you will need to install that too: 43Ubuntu does not install by default the *gcc* compiler or *meson* or *ninja*, so, before you can [compile any apps](#Compiling_EFL_Applications), you will need to install those too:
44 44
45```bash 45```bash
46sudo apt-get install gcc 46sudo apt-get install gcc meson ninja-build
47``` 47```
48 48
49Also note that, due to EFL's fast development rate, it is unlikely the PPA will provide by default the latest version of EFL. This means that many of the examples in this documentation will probably need tweaking to work. If you would like to install an up to date version of EFL, see the [Installing from Source](#Installing_from_Source) section below or the instructions for [Installing from Git](#Installing_from_Git), also available below. 49Also note that, due to EFL's fast development rate, it is unlikely the PPA will provide by default the latest version of EFL. This means that many of the examples in this documentation will probably need tweaking to work. If you would like to install an up to date version of EFL, see the [Installing from Source](#Installing_from_Source) section below or the instructions for [Installing from Git](#Installing_from_Git), also available below.
@@ -79,7 +79,7 @@ This will produce a folder called ``efl-X.XX.X``.
79Before you can compile and install EFL, you will have to install some software packages EFL needs: 79Before you can compile and install EFL, you will have to install some software packages EFL needs:
80 80
81```bash 81```bash
82sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libbullet-dev libgstreamer-plugins-base1.0-dev doxygen 82sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libavahi-client-dev libharfbuzz-dev libibus-1.0-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libbullet-dev libgstreamer-plugins-base1.0-dev doxygen
83``` 83```
84 84
85### Step 4: Building and Installing ### 85### Step 4: Building and Installing ###
@@ -87,9 +87,9 @@ sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev lib
87Once you have installed all the packages EFL needs, ``cd`` into the ``efl-X.XX.X`` folder and run 87Once you have installed all the packages EFL needs, ``cd`` into the ``efl-X.XX.X`` folder and run
88 88
89```bash 89```bash
90./configure 90meson build
91make 91ninja -C build
92sudo make install 92sudo ninja -C build install
93``` 93```
94 94
95This will configure the files needed for compiling, actually compile the software, and then install it. 95This will configure the files needed for compiling, actually compile the software, and then install it.
@@ -139,7 +139,7 @@ sudo apt install autoconf autopoint libtool
139As well as the dependencies specific for EFL: 139As well as the dependencies specific for EFL:
140 140
141```bash 141```bash
142sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libbullet-dev libgstreamer-plugins-base1.0-dev doxygen 142sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libavahi-client-dev libharfbuzz-dev libibus-1.0-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libbullet-dev libgstreamer-plugins-base1.0-dev doxygen
143``` 143```
144 144
145### Step 3: Configuring the Software ### 145### Step 3: Configuring the Software ###
@@ -147,14 +147,14 @@ sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev lib
147Now you can ``cd`` into the ``efl`` directory and run the ``autoreconf`` script to create and configure the software ready for compilation: 147Now you can ``cd`` into the ``efl`` directory and run the ``autoreconf`` script to create and configure the software ready for compilation:
148 148
149```bash 149```bash
150./autogen.sh 150meson build
151``` 151```
152 152
153Once configured, you can compile the software with: 153Once configured, you can compile the software with:
154 154
155```bash 155```bash
156make 156ninja -C build
157sudo make install 157sudo ninja -C build install
158``` 158```
159 159
160### Step 4: Carrying out Post Installation Tasks ### 160### Step 4: Carrying out Post Installation Tasks ###