summaryrefslogtreecommitdiff
path: root/pages/docs/distros/ubuntu-start.md.txt
diff options
context:
space:
mode:
authorPhilippe Jean Guillaumie <batden@sfr.fr>2021-03-16 23:58:46 -0700
committerwww-data <www-data@enlightenment.org>2021-03-16 23:58:46 -0700
commit0695574d6f8a8ad6e65c7478e0f87bf9e0879e84 (patch)
treed5fa7f209332665a7df46eae53ce629834a83001 /pages/docs/distros/ubuntu-start.md.txt
parent1c35a16a23819738fad950827c8228eed2c55a45 (diff)
Wiki page ubuntu-start.md changed with summary [Update dependencies] by Philippe Jean Guillaumie
Diffstat (limited to '')
-rw-r--r--pages/docs/distros/ubuntu-start.md.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/pages/docs/distros/ubuntu-start.md.txt b/pages/docs/distros/ubuntu-start.md.txt
index 8fb7f5458..0141ec715 100644
--- a/pages/docs/distros/ubuntu-start.md.txt
+++ b/pages/docs/distros/ubuntu-start.md.txt
@@ -59,10 +59,16 @@ This will produce a folder called ``efl-X.XX.X``.
59 59
60### Step 3: Installing Dependencies ### 60### Step 3: Installing Dependencies ###
61 61
62Before you can compile and install EFL, you will have to install some software packages EFL needs: 62You will need to install some tools to build EFL:
63
64```bash
65sudo apt install build-essential check meson ninja-build
66```
67
68As well as the dependencies specific for EFL:
63 69
64```bash 70```bash
65sudo apt install check libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libavahi-client-dev libharfbuzz-dev libibus-1.0-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libopenjp2-7-dev libwebp-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libgstreamer-plugins-base1.0-dev doxygen libscim-dev libxdamage-dev libwebp-dev libunwind-dev 71sudo apt install libssl-dev libsystemd-dev libjpeg-dev libglib2.0-dev libgstreamer1.0-dev libluajit-5.1-dev libfreetype6-dev libfontconfig1-dev libfribidi-dev libavahi-client-dev libharfbuzz-dev libibus-1.0-dev libx11-dev libxext-dev libxrender-dev libgl1-mesa-dev libopenjp2-7-dev libwebp-dev libgif-dev libtiff5-dev libpoppler-dev libpoppler-cpp-dev libspectre-dev libraw-dev librsvg2-dev libudev-dev libmount-dev libdbus-1-dev libpulse-dev libsndfile1-dev libxcursor-dev libxcomposite-dev libxinerama-dev libxrandr-dev libxtst-dev libxss-dev libgstreamer-plugins-base1.0-dev doxygen libscim-dev libxdamage-dev libwebp-dev libunwind-dev
66``` 72```
67 73
68### Step 4: Building and Installing ### 74### Step 4: Building and Installing ###