summaryrefslogtreecommitdiff
path: root/pages/docs/distros
diff options
context:
space:
mode:
authorPhilippe Jean Guillaumie <batden@sfr.fr>2021-03-16 12:13:30 -0700
committerwww-data <www-data@enlightenment.org>2021-03-16 12:13:30 -0700
commita76f8d5346681387a9e823d252b63b50ad1d2128 (patch)
treeb9ef13013cb3a357ef9e44b29dc5709313fefbe4 /pages/docs/distros
parent99a18c5d9456982717c09081874e66594a3e663e (diff)
Wiki page ubuntu-start.md changed with summary [] by Philippe Jean Guillaumie
Diffstat (limited to 'pages/docs/distros')
-rw-r--r--pages/docs/distros/ubuntu-start.md.txt31
1 files changed, 5 insertions, 26 deletions
diff --git a/pages/docs/distros/ubuntu-start.md.txt b/pages/docs/distros/ubuntu-start.md.txt
index 0dc4f00c1..dc4b53815 100644
--- a/pages/docs/distros/ubuntu-start.md.txt
+++ b/pages/docs/distros/ubuntu-start.md.txt
@@ -7,9 +7,7 @@
7 7
8This tutorial describes several ways to install EFL on your system. You will only need to use one of these. Select your chosen method using the index on the right. 8This tutorial describes several ways to install EFL on your system. You will only need to use one of these. Select your chosen method using the index on the right.
9 9
10Many distributions offer EFL as an installable package from their default repositories. In this case you only need to use your distribution's software management system to install. However most versions of EFL in default repositories are out of date and will not compile more recent Enlightenment applications. If this is not an issue for you, read through the ["From Distribution Repositories"](#From_Distribution_Repositories) section below. 10Many distributions offer EFL as installable packages from their default repositories. In this case you only need to use your distribution's software management system to install. However most versions of EFL in default repositories are out of date and will not compile more recent Enlightenment applications. If this is not an issue for you, read through the ["From Distribution Repositories"](#From_Distribution_Repositories) section below.
11
12Distributions often provide a special repository maintained by users or a method of integrating a bleeding edge version of EFL with your software management system. This means that once installed you can keep EFL current just by running system updates. If your distribution offers this, take a look at the section ["Installing from a Special Repository"](#Installing_from_a_Special_Repository).
13 11
14The Enlightenment developers provide a pre-packaged source of EFL. Although not bleeding edge it is up to date and considered stable for production environments. You can download, compile and install it yourself by following the instructions in ["Installing from Packaged Source"](#Installing_from_Packaged_Source). 12The Enlightenment developers provide a pre-packaged source of EFL. Although not bleeding edge it is up to date and considered stable for production environments. You can download, compile and install it yourself by following the instructions in ["Installing from Packaged Source"](#Installing_from_Packaged_Source).
15 13
@@ -17,34 +15,15 @@ You can also download the source code for the most recent version from the EFL g
17 15
18## From Distribution Repositories ## 16## From Distribution Repositories ##
19 17
20EFL is not available in Ubuntu's official repositories, but you can install all the items you need from a special PPA repository. [See below for instructions on how to do that](#Installing_from_a_Special_Repository). 18You can install all the items you need from Ubuntu's official repository:
21
22## Installing from a Special Repository ##
23
24To install the latest EFL available from a special Ubuntu PPA repository, add the new repository with:
25 19
26```bash 20```bash
27sudo add-apt-repository ppa:niko2040/e19 21sudo apt install libefl-all-dev libeet-bin libeina-bin
28``` 22```
29Refresh your repositories:
30
31```bash
32sudo apt update
33```
34
35And then install EFL and its development libraries:
36 23
37```bash 24This will give you a working EFL installation.
38sudo apt install libefl-dev
39```
40
41Ubuntu does not install by default the *gcc* compiler or *meson* or *ninja*, so, before you can compile any apps, you will need to install those too:
42
43```bash
44sudo apt install gcc meson ninja-build
45```
46 25
47Also note that, due to EFL's fast development rate, it is unlikely the PPA will provide by default the latest version of EFL. This means that many of the examples in this documentation will probably need tweaking to work. If you would like to install an up to date version of EFL, see the [Installing from Source](#Installing_from_Packaged_Source) section below or the instructions for [Installing from Git](#Installing_from_Git), also available below. 26However, the version in Ubuntu's official repositories may lag behind the latest version of EFL and give you problems when trying to compile examples from tutorials in this documentation. If this is the case, it is advised you install a more recent version of EFL following one of the methods below.
48 27
49## Installing from Packaged Source ## 28## Installing from Packaged Source ##
50 29